Outlook desktop client crashing on launch (Windows only)
Incident Report for Davidson College
Resolved
Microsoft has reported this issue is now resolved.
Posted Jul 16, 2020 - 09:30 EDT
Monitoring
Microsoft is reporting that most customers have received the fix. Microsoft will continue to monitor. Users still experiencing issues may need to restart their Outlook client for the fix to take effect.
Posted Jul 15, 2020 - 17:46 EDT
Investigating
Users may experience an issue when launching the Microsoft Outlook application. Microsoft is aware of the issue and is implementing a resolution; however, it may take several hours to complete. Please use outlook.davidson.edu to access your email and calendars as an alternative.
Posted Jul 15, 2020 - 14:40 EDT
This incident affected: Email.