Network outage
Incident Report for Davidson College
Resolved
We have resolved the issue with the distribution facility, and campus network services should be restored. Please get in touch with us at ti@davidson.edu or 704-894-2900 if you are still experiencing issues.
Posted Jan 12, 2023 - 08:08 EST
Investigating
We are investigating an issue with the network affecting a number of buildings on campus that are served from a distribution facility in Baker Sports Complex.

Affected buildings include the Alvarez College Union/Knobloch Campus Center and Baker, along with Armfield/Martin Court, some athletics facilities, and Physical Plant facilities.

T&I staff are working to restore service. Further updates will be posted as they are available.
Posted Jan 12, 2023 - 07:10 EST
This incident affected: Network & Internet Access (Internet Service, Wired Network, Wireless: eduroam, Wireless: DavidsonDevice, Wireless: DavidsonGuest, Wireless: Belk_Arena_Fan, Wireless: DavidsonGaming).