DegreeWorks Outage
Incident Report for Davidson College
Resolved
This incident has been resolved.
Posted May 18, 2020 - 15:36 EDT
Monitoring
Technicians have identified an issue that was preventing users from accessing the system. That problem has been resolved. We are awaiting confirmation from the registrar's office that the system is fully functional.
Posted May 18, 2020 - 12:25 EDT
Investigating
We are currently experiencing issues with our DegreeWorks application. Technicians are working on the issue and will provide updates as appropriate.
Posted May 18, 2020 - 11:55 EDT
This incident affected: Enterprise Applications (DegreeWorks).