Print Server Issue
Incident Report for Davidson College
Resolved
The print server is functioning normally again and printing on-campus has resumed. Please contact UST with any additional issues.
Posted Nov 13, 2020 - 09:02 EST
Identified
We have identified an issue with the server that facilitate printing through PawPrint. The server is being rebooted. It will not be possible to print until the server comes back online.
Posted Nov 13, 2020 - 08:48 EST
This incident affected: PawPrint.