Outage Notice: Davidson Directory and Apex-Hosted Applications

Incident Report for Davidson College

Resolved

This issue has been resolved, and the directory and apex-applications are again available.
Posted Jul 27, 2026 - 14:38 EDT

Investigating

All APEX-hosted applications, including the internal Davidson Directory, are currently unavailable. T&I is aware of this issue, and is actively working to address it.
Posted Jul 27, 2026 - 13:37 EDT