Oracle Cloud Service Issues

Incident Report for Davidson College

Resolved

Oracle has resolved this issue and functionality has been restored.
Posted Mar 03, 2026 - 09:08 EST

Investigating

Oracle Cloud is currently experiencing cloud service issues that are affecting functionality within the service. These issues appear to be limited at this time, and include functionality around purchase requests, time cards and search. T&I is investigating this issue and will update this status notice with further information as available.
Posted Mar 03, 2026 - 08:45 EST
This incident affected: Enterprise Applications (Oracle Cloud).