Outage Notice: PawPrint services are currently down for all printers

Incident Report for Davidson College

Resolved

The root cause of the printing issue was identified and resolved. All print services are available.
Posted Sep 13, 2026 - 12:05 EDT

Investigating

T&I is aware of an issue with PawPrint which is disrupting print services campus-wide. We are working with our vendors to determine the root cause and resolve the issue as quickly as possible.
Posted Sep 13, 2026 - 09:45 EDT
This incident affected: Enterprise Applications (PawPrint).