Microsoft Office 365 Intermittent Issues
Incident Report for Davidson College
Resolved
The Office 365 intermittent issues have been resolved.
Posted about 2 months ago. Aug 27, 2019 - 11:09 EDT
Investigating
Some users are reporting intermittent issues with Microsoft Office 365 applications. Users may see an error message when accessing Office 365 applications using certain web browsers. We have reported these issues to Microsoft and will provide updates as soon as they become available.
Posted about 2 months ago. Aug 26, 2019 - 10:56 EDT
This incident affected: Email.