Update to Duo Requiring Outlook Reauthentication

Incident Report for Davidson College

Monitoring

Starting July 29, 2026, Davidson's Technology & Innovation team is making a behind-the-scenes update to how multi-factor authentication (MFA) works for many of the applications you sign into with your Davidson account. This is part of a required update to keep our sign-in security current and supported. You may be required to reauthenticate to apps such as Outlook.

More information can be found here: https://support.ti.davidson.edu/hc/en-us/articles/42314708063127-Duo-Verification-Required-Prompts
Posted Jul 29, 2026 - 15:54 EDT
This incident affects: Authentication (Duo Security Push Delivery).