Outage Notification: Classroom Help Buttons
Incident Report for Davidson College
Resolved
This incident has been resolved.
Posted Sep 13, 2022 - 13:36 EDT
Investigating
The Crestron server that powers classroom help buttons is currently down, and as a result classroom help buttons are not functioning. If you need immediate classroom support, please call 704-894-2900.
Posted Sep 09, 2022 - 08:35 EDT
This incident affected: Teaching & Learning Platforms (Classroom Help Buttons).