Support Center ticket system (Zendesk) is currently down.
Incident Report for Davidson College
Resolved
Zendesk has reported the issues affecting the support site have now been resolved.
Posted Sep 16, 2019 - 16:33 EDT
Investigating
We have received notification that our support center ticketing application, Zendesk, is currently down. Zendesk is working to return functionality. We will provide additional updates as they become available. If you require technical support, please contact us at 704-894-2900.
Posted Sep 16, 2019 - 14:30 EDT
This incident affected: Misc. (T&I Support Center).