Outage Notice: PawPrint Printers

Incident Report for Davidson College

Resolved

The issue affecting the 479S PawPrint printers has been resolved. Print service to PawPrint printers should operate as normal. Contact ti@davidson.edu if you have any continuing issues.
Posted Aug 07, 2026 - 11:11 EDT

Investigating

T&I has received reports that some PawPrint printers on campus are experiencing connectivity issues. This issue appears to only affect the smaller 479S models. Technical teams are investigating this issue. We’ll provide updates as available on this Status Page.
Posted Aug 07, 2026 - 08:43 EDT
This incident affected: Enterprise Applications (PawPrint).