Catcard access service interruption
Incident Report for Davidson College
Resolved
Card access has been restored.
Posted 3 months ago. Jul 25, 2019 - 08:38 EDT
Investigating
T&I is currently investigating an issue with Catcard access to card readers around campus. Some users will experience issues getting into secure doors around campus including Watson and certain dorms.
Posted 3 months ago. Jul 25, 2019 - 08:22 EDT