Cable TV is down
Incident Report for Davidson College
Resolved
Cable TV service has been restored. If you experience any problems with access, please contact us at ti@davidson.edu.
Posted Sep 17, 2019 - 12:02 EDT
Investigating
We are currently experiencing a campus-wide issue with our Cable TV system. Our vendor is investigating the problem and we will provide updates as they become available.
Posted Sep 17, 2019 - 10:31 EDT
This incident affected: Campus Cable TV service.