Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 23, 2025 - 12:01 EST
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Dec 23, 2025 - 12:00 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 23, 2025 - 12:00 EST
Scheduled
On Tuesday, December 23 at 12:00pm, T&I will be limiting access to Amplify to the Davidson network through Winter Break. Faculty and staff can continue to utilize Amplify on campus, or off campus using VPN. Davidson computers are preloaded with the GlobalProtect VPN, which is accessed by clicking on the globe icon in your taskbar or menu bar.
Remote student access is not currently available over break; however, T&I’s Security Team will consider temporary VPN access for a student needing it for critical time-sensitive academic purposes. Contact the T&I Support Center (ti@davidson.edu) to request critical access.
Posted Dec 23, 2025 - 11:59 EST
This scheduled maintenance affected: Enterprise Applications (Amplify AI).