Microsoft Office 365 email
Incident Report for Davidson College
Resolved
Microsoft has repaired the root cause of the partial Office 365 email outage. Please report any further difficulties accessing email services to ti@davidson.edu.
Posted 3 months ago. Sep 19, 2018 - 14:54 EDT
Investigating
Microsoft Office 365 has reported service degradation with accessing webmail. Users may be unable to connect to the Exchange Online service. Microsoft is communicating with our organization and we will post updates once we have further information.
Posted 3 months ago. Sep 19, 2018 - 11:03 EDT
This incident affected: Email.