Network Maintenance
Incident Report for Davidson College
Resolved
Maintenance is completed for this evening. All network activities are back to normal.
Posted Jun 24, 2020 - 22:16 EDT
Investigating
Network maintenance is being performed. Brief Internet outages may occur during this maintenance.
Posted Jun 24, 2020 - 20:59 EDT
This incident affected: Network & Internet Access (Internet Service).