Login problems affecting Davidson applications

Incident Report for Davidson College

Resolved

Duo confirmed that they had deployed a fix to their environment at 11:38am, restoring services. T&I staff continued monitoring throughout the afternoon and did not receive further notices of service difficulties.

Duo has posted their own information about the outage and will post a root-cause analysis when complete: https://status.duo.com/incidents/byd2vdlp1rff
Posted Feb 23, 2026 - 17:27 EST

Monitoring

We are continuing to monitor updates from Duo and Microsoft on this morning's outage.

Currently, as a temporary measure, Davidson T&I has temporarily suspended the Duo requirement for Moodle, Zoom, email, and some academic applications. You should be able to sign in to those services without being prompted by Duo.

We are beginning to see signs that there maybe a service recovery underway for Duo-Microsoft login, although the vendors have not yet confirmed an all-clear. We will post further updates as they are known.
Posted Feb 23, 2026 - 11:20 EST

Investigating

We are experiencing widespread login issues affecting Davidson technology services. There appears to be an outage affecting Duo multi-factor authentication preventing single sign-on. We are working to gather more information at this time.
Posted Feb 23, 2026 - 09:23 EST
This incident affected: Authentication (Single Sign-On, Duo Security Core Authentication Service, Duo Security Push Delivery, Duo Security Phone Call Delivery).