Authentication outage affecting multiple Davidson websites
Incident Report for Davidson College
Resolved
This incident has been resolved.
Posted Mar 15, 2021 - 20:53 EDT
Update
Microsoft anticipates full worldwide recovery from this outage within the next 60 minutes. If everything goes as planned, we will resolve this incident at 7:00 PM.
Posted Mar 15, 2021 - 17:20 EDT
Monitoring
We are seeing some signs of recovery. Authentication to Davidson sites and services appears to be working for multiple sites and users. We will continue to monitor the situation until Microsoft formally resolves the outage.
Posted Mar 15, 2021 - 17:02 EDT
Update
Microsoft has identified an update that they believe caused the outage. They are in the process of rolling back the update. With any luck, authentication to Davidson services will be restored shortly. Next update by 5:00 PM.
Posted Mar 15, 2021 - 16:36 EDT
Update
Microsoft has confirmed a worldwide outage of their cloud directory service. We continue to monitor their status page and social media for additional updates.
Posted Mar 15, 2021 - 16:11 EDT
Identified
The outage appears to be originating from Microsoft's cloud directory platform, where faculty, staff, and student accounts are authenticated to Davidson web applications. The Microsoft outage appears to be widespread, affecting many other schools and industries beyond Davidson and higher ed. We will continue to look for updates from Microsoft and provide an ETA for resolution once we have one.
Posted Mar 15, 2021 - 15:41 EDT
Investigating
Duo authentication to Davidson applications appears to be malfunctioning. We are investigating. Next update by 3:45 PM.
Posted Mar 15, 2021 - 15:22 EDT
This incident affected: Authentication (Single Sign-On, Duo Security Core Authentication Service, Duo Security Push Delivery).