DegreeWorks Unavailable
Incident Report for Davidson College
Resolved
The DegreeWorks application is available again.
Posted Jul 01, 2020 - 13:08 EDT
Investigating
T&I is investigating an issue resulting in and outage for the DegreeWorks application. We will update this incident with more information when available.
Posted Jul 01, 2020 - 12:54 EDT
This incident affected: Enterprise Applications (DegreeWorks).