Users are unable to log into DegreeWorks
Incident Report for Davidson College
Resolved
This incident has been resolved.
Posted Jun 17, 2020 - 08:19 EDT
Identified
Technicians have identified an issue with a TLS certificate chain. We are working with our certificate vendor to resolve. In the meantime DegreeWorks continues to be accessible through BannerWeb.
Posted Jun 15, 2020 - 15:31 EDT
Update
We are continuing to investigate this issue.
Posted Jun 15, 2020 - 09:55 EDT
Investigating
Users are receiving error messages and cannot log into DegreeWorks. T&I staff are investigating the problem.
Posted Jun 15, 2020 - 09:34 EDT
This incident affected: Enterprise Applications (DegreeWorks).