Issue with Duo Desktop and Access to VPN and Other Services

Incident Report for Davidson College

Resolved

Davidson T&I identified the issue and has issued a new certificate for Duo Desktop. Service has been restored to Duo Desktop, VPN, and all services that utilize the application for trusted endpoint verification.
Posted May 01, 2026 - 13:44 EDT

Investigating

Davidson T&I is aware of an issue with Duo Desktop that is affecting access to VPN and other services that require trusted endpoints to access them, including Banner admin page and Etrive. This issue is related to security enhancements that impact how Duo Desktop connects to local networks. T&I is investigating this issue and will provide updates when available.
Posted May 01, 2026 - 12:01 EDT
This incident affected: Authentication (Duo Desktop).