Zoom Currently Unavailable
Incident Report for Davidson College
Resolved
Zoom engineers resolved this incident.
Posted Sep 15, 2022 - 11:30 EDT
Investigating
Zoom is investigating reports of zoom.us being unavailable.
Zoom support is currently investigating this issue. We will update when more information from Zoom becomes available.
Posted Sep 15, 2022 - 11:23 EDT
This incident affected: Web Conferencing, Telephone, and Chat (Zoom Zoom Meetings, Zoom Telephone Services, Zoom Zoom Video Webinars).