Students reporting Internet Connectivity Issues
Incident Report for Davidson College
Resolved
The issues with intermittent access to websites has been resolved. T&I will continue to monitor the network for any additional issues.
Posted Dec 14, 2022 - 11:02 EST
Monitoring
While T&I is continuing to monitor the situation and we are awaiting a formal report from our internet service provider that the outage has been resolved, known affected external websites are again available from the campus network. This matches reports from another affected NC university which is also noting a restoration of normal network performance on their campus.

We apologize for any inconvenience this outage caused, particularly at an important time of the semester.
Posted Dec 14, 2022 - 01:05 EST
Update
T&I staff are continuing to investigate. We are finding some web services (e.g., cnn.com, google.com) are loading properly, while others (including many universities as well as some sites connected through Internet2, the US higher education research network) are affected and appear to load slowly or not load.

At least one other university in North Carolina that shares a common internet service provider with Davidson is reporting similar issues.

Workarounds to consider include using the hotspot on your mobile phone for full internet access until service is restored. We will post more information as it becomes available.
Posted Dec 13, 2022 - 23:31 EST
Investigating
Students have reported issues with connecting to websites from the campus network. T&I is investigating.
Posted Dec 13, 2022 - 22:57 EST
This incident affected: Network & Internet Access (Internet Service).