Connecting to eduroam and new certificate

Incident Report for Davidson College

Resolved

The updated eduroam certificate is legitimate. Confirm or trust the certificate to stay connected to eduroam. The exact wording of the notice may change depending on what type of device you are using.

If you are unable to connect to eduroam, try forgetting the network in your Network settings and then reconnecting with your Davidson email address and password.
Posted Sep 17, 2026 - 14:33 EDT

Investigating

T&I will be updated settings on the eduroam WiFi network. Your phone or computer may prompt you to confirm or trust a new security certificate.

The updated eduroam certificate is legitimate. Confirm or trust the certificate to stay connected to eduroam. The exact wording of the notice may change depending on what type of device you are using.

If you are unable to connect to eduroam, try forgetting the network in your Network settings and then reconnecting with your Davidson email address and password.

If you have any questions, or want to check that something that you are seeing on your computer or phone is correct, please reach out to T&I at ti@davidson.edu or 704-894-2900.
Posted Sep 17, 2026 - 08:50 EDT
This incident affected: Network & Internet Access (Internet Service, Wireless: eduroam).