Softdocs Etrieve outage

Incident Report for Davidson College

Resolved

Access to Softdocs Etrieve has been restored. The vendor will continue to monitor the service.
Posted Jan 14, 2026 - 19:21 EST

Investigating

Davidson T&I is aware of the current Softdocs Etrieve outage. We are monitoring communications with our vendor partner and will take appropriate action as needed.
Posted Jan 14, 2026 - 16:48 EST
This incident affected: Enterprise Applications (Etrieve).