Belk WiFi down (3rd/4th floor)
Incident Report for Davidson College
Resolved
The equipment has been replaced and WiFi has been restored to the impacted areas. Thank you for your patience.
Posted Oct 25, 2019 - 10:49 EDT
Identified
T&I has identified an issue with WiFi on the 3rd and 4th floors of Belk. We are in the process of replacing the switch in order to restore service to the impacted areas. We will continue to monitor progress and post updates as needed.
Posted Oct 25, 2019 - 08:56 EDT
This incident affected: Network & Internet Access (Internet Service).