T&I Support Center (Zendesk) Unavailable
Incident Report for Davidson College
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 08, 2018 - 15:22 EDT
Update
The T&I support center ticketing software (Zendesk) has been restored. We will continue to monitor and update as needed. Thank you.
Posted 3 months ago. Aug 08, 2018 - 12:56 EDT
Identified
The T&I support center ticketing software (Zendesk) is currently unavailable due to a provider service outage. We are currently unable to respond to new or existing support tickets. We will provide an update as soon as service is restored.
Posted 3 months ago. Aug 08, 2018 - 12:20 EDT
This incident affected: T&I Support Center.