DavidsonGuest WiFi is down
Incident Report for Davidson College
Resolved
The DavidsonGuest WiFi issue has been resolved. If you have any issues, please contact us at ti@davidson.edu.
Posted Oct 21, 2019 - 10:54 EDT
Investigating
T&I is investigating an issue with DavidsonGuest WiFi access. We will provide updates as soon as we have more information.
Posted Oct 21, 2019 - 09:36 EDT
This incident affected: Network & Internet Access (Wireless: DavidsonGuest).