Vectorworks is unavailable
Incident Report for Davidson College
Resolved
The current version of Vectorworks has been installed, which resolved the issues.
Posted Aug 03, 2021 - 14:56 EDT
Investigating
The vectorworks application is unavailable at this time. T&I is looking into the issue and will update progress here.
Posted May 20, 2021 - 16:57 EDT
This incident affected: Misc. (Misc.).