Performance issues with Mac computers
Incident Report for Davidson College
Resolved
This incident has been resolved.
Posted Nov 12, 2020 - 19:11 EST
Monitoring
The affected parts of Apple's infrastructure seem to be coming back online. T&I staffers are seeing improvements in the performance of their college-issued Mac computers. We will continue to monitor until 6 PM EST before declaring this incident resolved.
Posted Nov 12, 2020 - 16:51 EST
Identified
Although Apple has yet to issue a statement or provide a root cause, based on what we are seeing on Apple's status page and elsewhere, we are confident that the issue resides with Apple's infrastructure. We are continuing to monitor their infrastructure for signs of improvement.
Posted Nov 12, 2020 - 16:39 EST
Investigating
T&I is aware of (and experiencing) extremely slow performance on Mac OS devices. While the cause of this issue remains unknown, it appears that many organizations (both corporate and higher ed) are encountering the same problem. We are investigating the issue to try and determine the root cause.
Posted Nov 12, 2020 - 16:03 EST