Office 365/Outlook "throttled" error message when signing in
Incident Report for Davidson College
Resolved
Several users affected by the "throttling" error are reporting that service is restored, and Microsoft is stating the outage is over.
Posted 18 days ago. Sep 05, 2018 - 19:45 EDT
Investigating
Some Outlook at Office 365 users are receiving a "throttled" error message when attempting to log in. This is due to a partial outage impacting Microsoft hosted services. Microsoft is reportedly making a change this afternoon to resolve this problem. We apologize for any inconvenience.

For more information, see USA Today's coverage at https://www.usatoday.com/story/money/nation-now/2018/09/05/outlook-microsoft-office-365-throttled-message-skype/1204854002/.
Posted 18 days ago. Sep 05, 2018 - 16:32 EDT
This incident affected: Email.