Course schedule outage
Incident Report for Davidson College
Resolved
We have been monitoring the course schedule's underlying infrastructure on and off throughout the day. While traffic remains high, the additional capacity and protections we have added seem to be holding firm. Postmortem to follow.
Posted Nov 15, 2021 - 16:26 EST
Monitoring
The Microsoft infrastructure component of the course schedule site is coming back online. We have added capacity to the service and increased its resiliency to reduce the chance of future outages in this component. Students should be seeing accurate, live course enrollment data at https://course-schedule.davidson.edu. We will continue to monitor the site and its underlying services as the day progresses.
Posted Nov 15, 2021 - 08:19 EST
Update
We are still waiting for the Microsoft service affecting add/drop to come back online. In the meantime, students wishing to add/drop classes may do so directly from Banner Self-Service.
Posted Nov 15, 2021 - 08:04 EST
Identified
High resource consumption caused an outage in one of the Microsoft services sitting in front of the code that retrieves courses and course enrollment. Engineers are bringing the service back online.
Posted Nov 15, 2021 - 07:56 EST
Investigating
High resource consumption through the course schedule site and higher than expected add/drop requests are causing problems for our infrastructure across the board. Engineers are working on the problem.
Posted Nov 15, 2021 - 07:41 EST