Laptop Kiosks Unavailable
Incident Report for Davidson College
Resolved
The laptops kiosks are operating correctly. We'll continue to update and service individual laptops to mitigate any lingering issues associated with the outage.
Posted 13 days ago. Sep 10, 2018 - 10:19 EDT
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Aug 21, 2018 - 13:41 EDT
Investigating
The laptop kiosks are currently unavailable for laptop checkout. We are working to resolve this issue and will post updates when they become available.
Posted about 1 month ago. Aug 21, 2018 - 13:41 EDT