Problems connecting to the Davidson Secure network
Incident Report for Davidson College
Resolved
The Davidson Secure network is fully functional. Please report any further issues to T&I.
Posted Mar 31, 2021 - 17:05 EDT
Update
We are continuing to monitor for any further issues.
Posted Mar 31, 2021 - 15:05 EDT
Monitoring
A fix has been implemented for the issue that was impacting Davidson Secure. T&I will continue to monitor connectivity to the network.
Posted Mar 31, 2021 - 13:04 EDT
Investigating
T&I has been made aware of issues connecting to the Davidson Secure network. Users that are already connected to Davidson Secure should continue to function. Users trying to create new connection will fail. Users can connect to Eduroam with their Davidson credentials for connectivity.

Technicians are working on the issue.
Posted Mar 31, 2021 - 11:58 EDT
This incident affected: Network & Internet Access (Wireless: DavidsonSecure).