Slack performance problems
Incident Report for Davidson College
Resolved
According to Slack, service was resolved at approximately 4:45pm.
Posted Oct 05, 2020 - 22:12 EDT
Monitoring
Slack has posted more information about their outage: https://status.slack.com/2020-10/e8c094cc99aabf64.

At this time we have not received confirmation of any other service outages impacting Davidson services. We will continue to monitor for updates.
Posted Oct 05, 2020 - 15:44 EDT
Investigating
T&I is aware of reports that some applications used on campus, including Slack and Kuali Build, are responding and loading slowly. We are aware of broader internet reports of performance issues impacting Amazon Web Services (AWS), which provides hosting services for both Slack and Kuali Build. For this reason, it is possible other software as a service (SaaS), cloud-hosted applications that rely on AWS could be experiencing outages.

This is a speculative alert and has not been confirmed by AWS or other vendors. T&I will monitor the situation.
Posted Oct 05, 2020 - 12:03 EDT
This incident affected: Web Conferencing and Chat (Slack Messaging) and Enterprise Applications (Kuali Build).