Network Maintenance
Incident Report for Davidson College
Resolved
Tonight's network maintenance activities are complete.
Posted Jun 25, 2020 - 22:31 EDT
Investigating
Tonight's scheduled network maintenance has begun.
Posted Jun 25, 2020 - 21:00 EDT
This incident affected: Network & Internet Access (Internet Service).