Reported issues with Cable TV channels
Incident Report for Davidson College
Resolved
This incident has been resolved.
Posted 8 days ago. Oct 09, 2019 - 16:03 EDT
Update
The Cable TV issues have been resolved. If you have additional questions, please email T&I at ti@davidson.edu.
Posted 8 days ago. Oct 09, 2019 - 14:01 EDT
Investigating
T&I is currently investigating cable tv channel issues reported from the Guest House and Jamieson. If you are experiencing cable issues please contact RLO or T&I.
Posted 8 days ago. Oct 09, 2019 - 12:38 EDT
This incident affected: Campus Cable TV service.