Campus-wide Power Issues (brown out)
Incident Report for Davidson College
Resolved
Duke Power has informed us that the repairs have been completed. The technicians will be back on-site this afternoon during peak load to verify that things are working as expected.
Posted Sep 04, 2019 - 14:32 EDT
Update
T&I is continuing to monitor this situation, as extended low-power/brownout conditions increase the risk of loss of network and telecommunications services to campus buildings. While there is no current impact to network services or performance, please be advised that there is a heightened risk of service interruptions at this time.

Should you experience interruptions in Internet, network or telephony service to campus buildings this evening, please call 704-894-2900 and select option 2 to report a network outage to our on-call staff.
Posted Sep 03, 2019 - 17:56 EDT
Investigating
We are currently experiencing a campus-wide drop in voltage due to unknown power issues in the area. Physical Plant is working with Duke Power to identify and resolve the issue. We will provide updates as they become available.
Posted Sep 03, 2019 - 16:15 EDT
This incident affected: Network & Internet Access (Internet Service, Wireless: eduroam, Wireless: DavidsonSecure, Wireless: DavidsonDevice, Wireless: DavidsonGuest, Wired Network).