Banner.davidson.edu is down
Incident Report for Davidson College
Resolved
The Banner issue has been resolved. If you experience further issues, please email us at ti@davidson.edu.
Posted about 2 months ago. Aug 19, 2019 - 17:04 EDT
Investigating
We are currently experiencing an issue with Banner.davidson.edu. T&I is aware of this issue and working to identify the problem. Additional information will be posted as soon as it becomes available. Bannerweb.davidson.edu has not been impacted by this issue.
Posted about 2 months ago. Aug 19, 2019 - 16:39 EDT
This incident affected: Enterprise Applications (Banner).