Network Maintenance
Incident Report for Davidson College
Resolved
Tonight's network maintenance activities have completed.
Posted Jun 26, 2020 - 22:35 EDT
Investigating
The network maintenance scheduled for this evening has begun.
Posted Jun 26, 2020 - 21:00 EDT
This incident affected: Network & Internet Access (Internet Service).