Microsoft Email Interruption
Incident Report for Davidson College
Resolved
Microsoft has reported that this issues is resolved and service restored.
Posted May 13, 2020 - 16:04 EDT
Monitoring
Microsoft has posted a message that the issue has been resolved. We are asking people who were impacted to log into their Exchange Online accounts to ensure the issue is truly resolved.
Posted May 13, 2020 - 15:59 EDT
Investigating
We are currently aware of an issue affecting access to Davidson outlook accounts, stemming from an issue with Microsofts Exchange Online service. This issue is affecting email access outside of Davidson as well. We are awaiting an update from Microsoft.
Posted May 13, 2020 - 15:20 EDT
This incident affected: Email.