Issues with Symptom Tracker
Incident Report for Davidson College
Resolved
Users are able to utilize Symptom Tracker again. This issue is resolved.
Posted Mar 03, 2021 - 16:38 EST
Investigating
Some users are reporting issues with accessing Symptom Tracker. T&I is investigating.
Posted Mar 03, 2021 - 10:29 EST
This incident affected: Misc. (Misc.).