Unable to upload documents to OnBase
Incident Report for Davidson College
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 13:07 EST
Investigating
We are aware of an investigating an issue that is preventing the upload of documents into OnBase.
Posted Nov 18, 2020 - 11:48 EST
This incident affected: Enterprise Applications (OnBase).