704-894-2900 does not ring and emails are not delivered to ti@davidson.edu
Incident Report for Davidson College
Resolved
We have resolved the issues with contacting ti@davidson.edu, calling 704-894-2900. The Knowledge Base is now accessible. Please let us know if there are any lingering issues and thank you for your patience this morning.
Posted Nov 10, 2023 - 11:40 EST
Update
We can now receive emails at ti@davidson.edu, and phone calls at 704-894-2900. The Knowledge Base remains inaccessible at this time.
Posted Nov 10, 2023 - 10:14 EST
Identified
We are currently experiencing an outage with our Support Center. Calls are not delivered to 704-894-2900, and emails are not delivered to ti@davidson.edu. We expect this is related to an ongoing contract negotiation and will be resolved shortly.
Posted Nov 10, 2023 - 08:30 EST
This incident affected: Misc. (T&I Support Center).