Issue accessing outlook.davidson.edu on Safari
Incident Report for Davidson College
Resolved
The issue accessing outlook.davidson.edu on Safari has been resolved. If you have questions or need assistance, please contact us at ti@davidson.edu.
Posted Dec 12, 2019 - 15:09 EST
Identified
We are currently investigating an issue accessing webmail (outlook.davidson.edu) on Safari (Mojave operating system). Microsoft is aware of this issue and is working on a resolution. We recommend using an alternate browser, such as Chrome, until the issue is resolved. We will provide updates as soon as they become available.
Posted Dec 09, 2019 - 11:32 EST
This incident affected: Enterprise Applications (Microsoft Office 365).