Degree Works is down
Incident Report for Davidson College
Resolved
The issue with Degree Works has been resolved. If you continue to have problems with access, please contact us at ti@davidson.edu.
Posted Oct 21, 2019 - 14:10 EDT
Investigating
T&I is aware of the issue and currently investigating the problem. We will post updates as soon as they become available. Thank you for your patience.
Posted Oct 21, 2019 - 13:19 EDT