T&I Support Center Down
Incident Report for Davidson College
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 18:23 EDT
Investigating
Zendesk, our Support Center platform, is investigating widespread issues.
Posted Jul 17, 2020 - 18:10 EDT
This incident affected: T&I Support Center.