Password sync issues reported with Microsoft Office 365
Incident Report for Davidson College
Resolved
The Microsoft Office 365 webmail sync issue has been resolved.
Posted 2 months ago. Aug 13, 2019 - 18:07 EDT
Investigating
We have reports of sync issues with Microsoft Office 365 webmail (outlook.davidson.edu) following a password reset. We are currently investigating the issue and will post updates as soon as they are available.
Posted 2 months ago. Aug 13, 2019 - 14:55 EDT
This incident affected: Email.