Microsoft Bookings intermittent service interruptions
Incident Report for Davidson College
Resolved
This incident has been resolved.
Posted Mar 01, 2021 - 15:41 EST
Monitoring
At this time, Microsoft Bookings services appear to be working normally. In conversations with our vendor, we were unable to determine a root cause. Please contact the T&I Support Center if you are experiencing problems with Bookings or any other Davidson technology services.
Posted Feb 24, 2021 - 16:48 EST
Investigating
T&I has received reports of intermittent difficulties accessing the Microsoft Bookings tool. We are investigating and will provide more information as we have it.
Posted Feb 24, 2021 - 09:33 EST